11th Gen Civic Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,
I have a no heat issue with my 2004 civic sir.
the hoses going into and out or the heater core are both hot. The fam blows, the fluid is full, the blend door for air flow position works. Just blows cold air.
I would be very grateful if someone could give me some advice.
thanks in advance
 

·
Registered
Joined
·
1,796 Posts
If this was after the cooling system was opened up for any reason then I would suggest it is a classic case of air in the system, bleeding the system of air always does the trick. But if you have not had the cooling system open for any reason then there may be a mechanical issue for this. I used to get that issue after a cooling system fluid change, and only a bleed procedure was needed.

Secondly there is a cable that flips the coolant flow vale open to the heater core, it is near the firewall in the engine bay, make sure the cable had not come loose from the flow valve. It opens and closes as you switch from hot to cold temps inside the cabin.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
If this was after the cooling system was opened up for any reason then I would suggest it is a classic case of air in the system, bleeding the system of air always does the trick. But if you have not had the cooling system open for any reason then there may be a mechanical issue for this. I used to get that issue after a cooling system fluid change, and only a bleed procedure was needed. Secondly there is a cable that flips the coolant flow vale open to the heater core, it is near the firewall in the engine bay, make sure the cable had not come loose from the flow valve. It opens and closes as you switch from hot to cold temps inside the cabin.
Thank you!! The valve at the firewall is set to heat I’m have not opened the cooling system, but I just picked up the car so maybe the previous owner did. I’m spoke to him recently and he said it just stopped suddenly. side not the AC does not work either. I’ll flush the system today and see if that helps. thanks again for taking the time to respond
 
1 - 4 of 4 Posts
Top